deadthings

Members
  • Content Count

    12
  • Joined

  • Last visited

Everything posted by deadthings

  1. Ever since the ATLAS release at the end of August, I haven't been able to get sendmany to work properly with alqo-cli. It always throws the error... error: {"code":-4,"message":"Insufficient funds."} ...even though I know with 100% certainty that the amounts being passed to it should be leaving 2 XLQ buffer for fees - which should be way more than enough, right? Has anybody else run into this issue and found a solution or workaround? To reiterate - my sendmany script worked for many months just fine prior to the first ATLAS release, and then never again since.
  2. deadthings

    sendmany API call not working since ATLAS

    I'm just gonna open up an issue on GitHub. The Alqo Hub doesn't seem like a very useful resource, I'm afraid.
  3. deadthings

    sendmany API call not working since ATLAS

    Hello? Any info?
  4. deadthings

    sendmany API call not working since ATLAS

    Checking in on the status of this inquiry. FYI, we are thinking of including Alqo as one the cyrptocurrencies accepted by a new online service we hope to launch in Q1 2019, but if we cannot automate send functions using alqo-cli, then we won't be able to integrate it. FWIW, send functions using bulwark-cli work fine, and Bulwark is based on a very similar codebase as Alqo. Also, as I noted previously, send functions using alqo-cli also worked fine until the Atlas release.
  5. deadthings

    sendmany API call not working since ATLAS

    So sendmany is the cli equivalent of a multi-recipient transaction using the Qt. However, while a multi-recipient transaction using the Qt works perfectly well with the Atlas update, it does not using the cli. For some reason, it seems to misallocate inputs or fees, preventing the transaction from going through due to insufficient funds (even though, in reality, the funds are there). The same is also true of the much more common sendtoaddress - which is just a good old fashioned send command. Works on the Qt, but not in the cli, with the same error as mentioned above. edit - I should note that perhaps a contributing factor is that one of the inputs in the address from which I am attempting to send is locked for masternode collateral, in case you are trying to reproduce the error. But that's just a hunch, really - I have no evidence to support that.
  6. deadthings

    sendmany API call not working since ATLAS

    May I ask politely... what exactly is the point of this support hub, if not to provide support?
  7. deadthings

    sendmany API call not working since ATLAS

    FYI, even a series of sendtoaddress calls fails in the same way. The first few will go through, but the last ones will error out with the Insufficient funds message.